BeniComp Select Portal issue

Incident Report for BeniComp Health Solutions, Inc.

Resolved

The incident has been resolved. The issue was a frozen networking device.
Posted Sep 18, 2025 - 11:59 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 18, 2025 - 11:56 EDT

Identified

The issue has been identified and we are applying a fix
Posted Sep 18, 2025 - 11:40 EDT

Investigating

We are currently investigating this issues
Posted Sep 18, 2025 - 11:34 EDT
This incident affected: BeniComp Select Portal (select.benicomp.com).